CentOS 5.5 への OTRS 3.0 のインストール

From OtterHub - OTRS Community Wiki
Jump to: navigation, search

CentOS 5.5 に OTRS 3.0.1 をインストールする方法

最低必要条件

CentOS 5.5 の基本インストールに対して以下の設定を行っていること:

  • CentOS SELinux で SELinux 設定が permissive となっていること。
  • CentOS ファイアウォールで WWW(HTTP) が信頼できるサービスなっていなければならない。

OTRS が動作するためには、Apache ウェブサーバおよびバックエンドデータベースが正しく設定され動作している必要があります。CentOS 5.5 の基本インストールには、データベースのない Apache のインストールが含まれています。Apache と MySQL(筆者が選択したデータベース)を基本設定するための手順を以下に示します。

インターネットに接続されていること。

訳注: 訳者は本文書の手順を以下の環境で検証しました。本文書中のバージョンその他の記述は、読者の環境に応じて読み替えてください。

  • CentOS のバージョン: CentOS 5.5 x86_64
  • OTRS のバージョン: OTRS 3.0.3

Apache

以下のコマンドを実行して Apache(httpd)がインストールされていることを確認してください。httpd.<何とか> がインストールされたパッケージ通りであることを確かめます。

# yum list httpd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Installed Packages
httpd.x86_64                    2.2.3-43.el5.centos                    installed

httpd のランレベルの初期値を確認します:

# chkconfig --list httpd
httpd           0:off   1:off   2:off   3:off   4:off   5:off   6:off

各ランレベルで httpd を有効にします:

# chkconfig httpd on

各ランレベルで httpd が有効になっているかどうか確認します:

# chkconfig --list httpd
httpd           0:off   1:off   2:on    3:on    4:on    5:on    6:off

httpd を起動します:

# service httpd start

MySQL

筆者は MySQL(mysqld)を RPM や ソースファイルからではなく、yum を使用してインストールしました。グループコマンドを使用して MySQL グループ全体をインストールすることも、パッケージを個々に選択することも可能です。筆者は個々のパッケージを選択するやり方でインストールしました。

ここでは、個別選択とグループインストールの両方の手順を以下に説明します。

MySQL データベースグループをインストールする

グループインストールを行ってよいかどうか判断するために、yum を使用して、どのパッケージが MySQL グループで使用されるか照会します:

# yum groupinfo 'MySQL Database'
Loaded plugins: fastestmirror
Setting up Group Process
Loading mirror speeds from cached hostfile
 * addons: mirror.steadfast.net
 * base: mirror.nexcess.net
 * extras: mirror.steadfast.net
 * updates: mirrors.gigenet.com

Group: MySQL Database
 Description: This package group contains packages useful for use with MySQL.
 Mandatory Packages:
   mysql
 Default Packages:
   MySQL-python
   libdbi-dbd-mysql
   mysql-connector-odbc
   mysql-server
   perl-DBD-MySQL
   unixODBC
 Optional Packages:
   mod_auth_mysql
   mysql-bench
   mysql-devel
   php-mysql
   qt-MySQL

MySQL グループをインストールするには以下のコマンドを使用します(個別パッケージをインストールする場合はこの手順をスキップします):

# yum groupinstall 'MySQL Database'

MySQL 個別パッケージをインストールする

以下は、筆者が個別パッケージをインストールした際に使用したコマンドです:

# yum install mysql-server mysql php-mysql
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.i386 0:5.0.77-4.el5_5.3 set to be updated
--> Processing Dependency: perl(DBI) for package: mysql
---> Package mysql.x86_64 0:5.0.77-4.el5_5.3 set to be updated
---> Package mysql-server.x86_64 0:5.0.77-4.el5_5.3 set to be updated
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server
---> Package php-mysql.x86_64 0:5.1.6-27.el5 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5 for package: php-mysql
--> Processing Dependency: php-pdo for package: php-mysql
--> Running transaction check
---> Package perl-DBD-MySQL.x86_64 0:3.0007-2.el5 set to be updated
---> Package perl-DBI.x86_64 0:1.52-2.el5 set to be updated
---> Package php-common.x86_64 0:5.1.6-27.el5 set to be updated
---> Package php-pdo.x86_64 0:5.1.6-27.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch         Version                  Repository     Size
================================================================================
Installing:
 mysql                i386         5.0.77-4.el5_5.3         updates       4.8 M
 mysql                x86_64       5.0.77-4.el5_5.3         updates       4.8 M
 mysql-server         x86_64       5.0.77-4.el5_5.3         updates       9.8 M
 php-mysql            x86_64       5.1.6-27.el5             base           89 k
Installing for dependencies:
 perl-DBD-MySQL       x86_64       3.0007-2.el5             base          148 k
 perl-DBI             x86_64       1.52-2.el5               base          600 k
 php-common           x86_64       5.1.6-27.el5             base          153 k
 php-pdo              x86_64       5.1.6-27.el5             base           66 k

Transaction Summary
================================================================================
Install       8 Package(s)
Upgrade       0 Package(s)

Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): php-pdo-5.1.6-27.el5.x86_64.rpm                   |  66 kB     00:00     
(2/8): php-mysql-5.1.6-27.el5.x86_64.rpm                 |  89 kB     00:00     
(3/8): perl-DBD-MySQL-3.0007-2.el5.x86_64.rpm            | 148 kB     00:00     
(4/8): php-common-5.1.6-27.el5.x86_64.rpm                | 153 kB     00:00     
(5/8): perl-DBI-1.52-2.el5.x86_64.rpm                    | 600 kB     00:00     
(6/8): mysql-5.0.77-4.el5_5.3.i386.rpm                   | 4.8 MB     00:17     
(7/8): mysql-5.0.77-4.el5_5.3.x86_64.rpm                 | 4.8 MB     00:15     
(8/8): mysql-server-5.0.77-4.el5_5.3.x86_64.rpm          | 9.8 MB     00:24     
--------------------------------------------------------------------------------
Total                                           355 kB/s |  20 MB     00:58     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-DBI                                                 1/8 
  Installing     : mysql                                                    2/8 
  Installing     : php-common                                               3/8 
  Installing     : php-pdo                                                  4/8 
  Installing     : perl-DBD-MySQL                                           5/8 
  Installing     : mysql                                                    6/8 
  Installing     : mysql-server                                             7/8 
  Installing     : php-mysql                                                8/8 

Installed:
  mysql.i386 0:5.0.77-4.el5_5.3              mysql.x86_64 0:5.0.77-4.el5_5.3    
  mysql-server.x86_64 0:5.0.77-4.el5_5.3     php-mysql.x86_64 0:5.1.6-27.el5    

Dependency Installed:
  perl-DBD-MySQL.x86_64 0:3.0007-2.el5       perl-DBI.x86_64 0:1.52-2.el5       
  php-common.x86_64 0:5.1.6-27.el5           php-pdo.x86_64 0:5.1.6-27.el5      

Complete!

これで mysqld はインストールされましたが、ランレベルはまだ設定されていません:

# chkconfig --list mysqld
mysqld          0:off   1:off   2:off   3:off   4:off   5:off   6:off

ランレベル 2、3、5 で MySQL を有効にします:

# chkconfig --levels 235 mysqld on

mysqld のランレベルを確認します:

# chkconfig --list mysqld
mysqld          0:off   1:off   2:on    3:on    4:off   5:on    6:off

MySQL を初回起動する

mysqld を起動します。初めて mysqld を起動した際には親しみやすい通知メッセージが表示されます:

# service mysqld start

<<途中省略>>

Starting MySQL:  [  OK  ]

ここで我々は神の啓示に従い、mysql セキュアインストールスクリプトを実行します:

# /usr/bin/mysql_secure_installation

mysqld インストールのセキュア化に関する質問がいくつか表示されます:

<<途中省略>>

Set root password? [Y/n] Y

New password: 
Re-enter new password: 
Password updated successfully!
Reloading privilege tables..
 ... Success!

Remove anonymous users? [Y/n] Y
 ... Success!

Disallow root login remotely? [Y/n] Y
 ... Success!

Remove test database and access to it? [Y/n] Y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reload privilege tables now? [Y/n] Y
 ... Success!

Cleaning up...


All done!  If you've completed all of the above steps, your MySQL
installation should now be secure.

Thanks for using MySQL!

以上で MySQL は OTRS で使用できる状態になっているはずです。

OTRS

$ wget http://ftp.otrs.org/pub/otrs/RPMS/fedora/4/otrs-3.0.1-01.noarch.rpm

ファイルの MD5 ハッシュが http://otrs.org/download/ のエントリと一致するか調べて整合性を確認します。

 md5sum otrs-3.0.1-01.noarch.rpm 
e1ab127ea6b70ed1387447d340dfc4e0  otrs-3.0.1-01.noarch.rpm

依存関係を解決する

otrs rpm ファイルの依存関係を確認します:

# rpm -qpR otrs-3.0.1-01.noarch.rpm
perl  
perl-DBI  
perl-DBD-MySQL  
perl-URI  
mod_perl  
httpd  
mysql  
mysql-server  
procmail  
perl-libwww-perl  
perl-Net-DNS  
perl-IO-Socket-SSL  
perl-XML-Parser  
/bin/sh

システムにクエリを発行するか、インストールを強行して表示されるエラーを読み取ることで、どのパッケージが不足しているか確認できます。筆者はインストールを強行して表示されるエラーを読み取る方法を選択しました:

# rpm -ivh otrs-3.0.1-01.noarch.rpm 
error: Failed dependencies:
        perl-URI is needed by otrs-3.0.0-beta1.noarch
        mod_perl is needed by otrs-3.0.0-beta1.noarch
        perl-libwww-perl is needed by otrs-3.0.0-beta1.noarch
        perl-Net-DNS is needed by otrs-3.0.0-beta1.noarch
        perl-IO-Socket-SSL is needed by otrs-3.0.0-beta1.noarch
        perl-XML-Parser is needed by otrs-3.0.0-beta1.noarch

これでどの依存モジュールをインストールすべきか判明しました。

備考: 別の方法として yum を使用しても RPM をインストールでき、その場合は依存関係を自動的に解決してくれます。しかしながら、あなたが今この文書を読んでいるということは、練習しておいても良いかも、と思ったわけです。

備考: yum コマンドの後に各パッケージをスペースで区切って列挙するだけで、全ての依存パッケージを直ちにインストールできます(上記で mysql の単体パッケージをインストールしたやり方と同じです)。しかしながら、あなたが今この文書を読んでいるということは、練習しておいても良いかも、と思ったわけです(^^)。

perl-URI の依存関係を解決します:

# yum install perl-URI
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-URI.noarch 0:1.35-3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch              Version            Repository       Size
================================================================================
Installing:
 perl-URI            noarch            1.35-3             base            116 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 116 k
Is this ok [y/N]: y
Downloading Packages:
perl-URI-1.35-3.noarch.rpm                               | 116 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-URI                                                 1/1 

Installed:
  perl-URI.noarch 0:1.35-3                                                      

Complete!

mod_perl の依存関係を解決します:

# yum install mod_perl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mod_perl.x86_64 0:2.0.4-6.el5 set to be updated
--> Processing Dependency: perl(BSD::Resource) for package: mod_perl
--> Running transaction check
---> Package perl-BSD-Resource.x86_64 0:1.28-1.fc6.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch          Version               Repository   Size
================================================================================
Installing:
 mod_perl                 x86_64        2.0.4-6.el5           base        4.0 M
Installing for dependencies:
 perl-BSD-Resource        x86_64        1.28-1.fc6.1          base         29 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 4.1 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): perl-BSD-Resource-1.28-1.fc6.1.x86_64.rpm         |  29 kB     00:00     
(2/2): mod_perl-2.0.4-6.el5.x86_64.rpm                   | 4.0 MB     00:00     
--------------------------------------------------------------------------------
Total                                           3.9 MB/s | 4.1 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-BSD-Resource                                        1/2 
  Installing     : mod_perl                                                 2/2 

Installed:
  mod_perl.x86_64 0:2.0.4-6.el5                                                 

Dependency Installed:
  perl-BSD-Resource.x86_64 0:1.28-1.fc6.1                                       

Complete!

perl-libwww-perl の依存関係を解決します:

# yum install perl-libwww-perl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-libwww-perl.noarch 0:5.805-1.1.1 set to be updated
--> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-libwww-perl
--> Processing Dependency: perl(HTML::Entities) for package: perl-libwww-perl
--> Processing Dependency: perl(Compress::Zlib) for package: perl-libwww-perl
--> Running transaction check
---> Package perl-Compress-Zlib.x86_64 0:1.42-1.fc6 set to be updated
---> Package perl-HTML-Parser.x86_64 0:3.55-1.fc6 set to be updated
--> Processing Dependency: perl-HTML-Tagset >= 3.03 for package: perl-HTML-Parser
--> Processing Dependency: perl(HTML::Tagset) for package: perl-HTML-Parser
--> Running transaction check
---> Package perl-HTML-Tagset.noarch 0:3.10-2.1.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                   Arch          Version              Repository   Size
================================================================================
Installing:
 perl-libwww-perl          noarch        5.805-1.1.1          base        376 k
Installing for dependencies:
 perl-Compress-Zlib        x86_64        1.42-1.fc6           base         52 k
 perl-HTML-Parser          x86_64        3.55-1.fc6           base         92 k
 perl-HTML-Tagset          noarch        3.10-2.1.1           base         15 k

Transaction Summary
================================================================================
Install       4 Package(s)
Upgrade       0 Package(s)

Total download size: 534 k
Is this ok [y/N]: y
Downloading Packages:
(1/4): perl-HTML-Tagset-3.10-2.1.1.noarch.rpm            |  15 kB     00:00     
(2/4): perl-Compress-Zlib-1.42-1.fc6.x86_64.rpm          |  52 kB     00:00     
(3/4): perl-HTML-Parser-3.55-1.fc6.x86_64.rpm            |  92 kB     00:00     
(4/4): perl-libwww-perl-5.805-1.1.1.noarch.rpm           | 376 kB     00:00     
--------------------------------------------------------------------------------
Total                                           858 kB/s | 534 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-Compress-Zlib                                       1/4 
  Installing     : perl-HTML-Tagset                                         2/4 
  Installing     : perl-HTML-Parser                                         3/4 
  Installing     : perl-libwww-perl                                         4/4 

Installed:
  perl-libwww-perl.noarch 0:5.805-1.1.1                                         

Dependency Installed:
  perl-Compress-Zlib.x86_64 0:1.42-1.fc6  perl-HTML-Parser.x86_64 0:3.55-1.fc6 
  perl-HTML-Tagset.noarch 0:3.10-2.1.1   

Complete!

perl-Net-DNS の依存関係を解決します:

[root@null-0023ae875f47 opt]# yum install perl-Net-DNS
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Net-DNS.x86_64 0:0.59-3.el5 set to be updated
--> Processing Dependency: perl(Digest::HMAC_MD5) for package: perl-Net-DNS
--> Processing Dependency: perl(Net::IP) for package: perl-Net-DNS
--> Running transaction check
---> Package perl-Digest-HMAC.noarch 0:1.01-15 set to be updated
--> Processing Dependency: perl(Digest::SHA1) for package: perl-Digest-HMAC
---> Package perl-Net-IP.noarch 0:1.25-2.fc6 set to be updated
--> Running transaction check
---> Package perl-Digest-SHA1.x86_64 0:2.11-1.2.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch           Version             Repository    Size
================================================================================
Installing:
 perl-Net-DNS             x86_64         0.59-3.el5          base         215 k
Installing for dependencies:
 perl-Digest-HMAC         noarch         1.01-15             base          12 k
 perl-Digest-SHA1         x86_64         2.11-1.2.1          base          49 k
 perl-Net-IP              noarch         1.25-2.fc6          base          31 k

Transaction Summary
================================================================================
Install       4 Package(s)
Upgrade       0 Package(s)

Total download size: 306 k
Is this ok [y/N]: y
Downloading Packages:
(1/4): perl-Digest-HMAC-1.01-15.noarch.rpm               |  12 kB     00:00     
(2/4): perl-Net-IP-1.25-2.fc6.noarch.rpm                 |  31 kB     00:00     
(3/4): perl-Digest-SHA1-2.11-1.2.1.x86_64.rpm            |  49 kB     00:00     
(4/4): perl-Net-DNS-0.59-3.el5.x86_64.rpm                | 215 kB     00:00     
--------------------------------------------------------------------------------
Total                                           565 kB/s | 306 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-Digest-SHA1                                         1/4 
  Installing     : perl-Digest-HMAC                                         2/4 
  Installing     : perl-Net-IP                                              3/4 
  Installing     : perl-Net-DNS                                             4/4 

Installed:
  perl-Net-DNS.x86_64 0:0.59-3.el5                                              

Dependency Installed:
  perl-Digest-HMAC.noarch 0:1.01-15     perl-Digest-SHA1.x86_64 0:2.11-1.2.1    
  perl-Net-IP.noarch 0:1.25-2.fc6      

Complete!

perl-IO-Socket-SSL の依存関係を解決します:

# perl-IO-Socket-SSL
-bash: perl-IO-Socket-SSL: command not found
[root@null-0023ae875f47 opt]# perl-IO-Socket-SSyum L
-bash: perl-IO-Socket-SSyum: command not found
[root@null-0023ae875f47 opt]# yum install perl-IO-Socket-SSL
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-IO-Socket-SSL.noarch 0:1.01-1.fc6 set to be updated
--> Processing Dependency: perl(Net::SSLeay) >= 1.21 for package: perl-IO-Socket-SSL
--> Running transaction check
---> Package perl-Net-SSLeay.x86_64 0:1.30-4.fc6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                   Arch          Version              Repository   Size
================================================================================
Installing:
 perl-IO-Socket-SSL        noarch        1.01-1.fc6           base         49 k
Installing for dependencies:
 perl-Net-SSLeay           x86_64        1.30-4.fc6           base        192 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 241 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): perl-IO-Socket-SSL-1.01-1.fc6.noarch.rpm          |  49 kB     00:00     
(2/2): perl-Net-SSLeay-1.30-4.fc6.x86_64.rpm             | 192 kB     00:00     
--------------------------------------------------------------------------------
Total                                           785 kB/s | 241 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-Net-SSLeay                                          1/2 
  Installing     : perl-IO-Socket-SSL                                       2/2 

Installed:
  perl-IO-Socket-SSL.noarch 0:1.01-1.fc6                                        

Dependency Installed:
  perl-Net-SSLeay.x86_64 0:1.30-4.fc6                                           

Complete!

perl-XML-Parser の依存関係を解決します:

# yum install perl-XML-Parser
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.trouble-free.net
 * base: mirror.steadfast.net
 * extras: mirror.trouble-free.net
 * updates: styx.biochem.wfubmc.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-XML-Parser.x86_64 0:2.34-6.1.2.2.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch          Version                 Repository   Size
================================================================================
Installing:
 perl-XML-Parser        x86_64        2.34-6.1.2.2.1          base        210 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 210 k
Is this ok [y/N]: y
Downloading Packages:
perl-XML-Parser-2.34-6.1.2.2.1.x86_64.rpm                | 210 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-XML-Parser                                          1/1 

Installed:
  perl-XML-Parser.x86_64 0:2.34-6.1.2.2.1                                       

Complete!

RPM コマンドを使用してインストールする

yum を使用して OTRS RPM をインストールします:

# yum --nogpgcheck install otrs-3.0.1-01.noarch.rpm 

<途中省略>

Next steps: 

[httpd services]
 Restart httpd 'service httpd restart'

[mysqld service]
 Start mysqld 'service mysqld start'

[install the OTRS database]
 Use a webbrowser and open this link:
 http://CentOShostname/otrs/installer.pl

[OTRS services]
 Start OTRS 'service otrs start' (service otrs {start|stop|status|restart).

((enjoy))

 Your OTRS Team

  Cleanup        : otrs                                                     3/3 

Dependency Installed:
  perl-TimeDate.noarch 1:1.16-5.el5                                             

Updated:
  otrs.noarch 0:3.0.1-01                                                        

Complete!

Apache の基本設定を行う

ファイル httpd.conf のバックアップを作成します。

# cp httpd.conf httpd.conf.back

ファイル httpd.conf を編集します:

# vi httpd.conf

最低限、修正が必要なエントリは以下の通りです:

ServerAdmin ptay@yourdomain.com
ServerName [hostname or IP address]:80
Listen yourIP:80

httpd を再起動します:

# service httpd restart
Stopping httpd: [  OK  ]
Starting httpd: [  OK  ]

MySQL データベースをセットアップする

単に OTRS docs ページに示される手順に従うだけです。便利な Web インストーラを提供してくれてありがとう、OTRS dev !

If on same machine as OTRS install you point your browser to http://localhost/otrs/installer.pl otherwise replace localhost with domain name or IP address.

OTRS にログインする

Web インストーラで MySQL を設定し終えたら、http://IPaddress/otrs/index.pl から OTRS に、ユーザ root@localhost に初期パスワードでログインできるようになっているはずです。

OTRS を使おう!

筆者 ptay の wiki

このガイドの原稿は my personal wiki にて保守されます。

翻訳元